WPF - World Photography Forum
Home Gallery Register FAQ Calendar Search Today's Posts Mark Forums Read

Welcome to World Photography Forum!
Welcome!

Thank you for finding your way to World Photography Forum, a dedicated community for photographers and enthusiasts. There's a variety of forums, a wonderful gallery, and what's more, we are absolutely FREE. You are very welcome to join, take part in the discussion, and post your pictures!

Click here to go to the forums home page and find out more.
Click here to join.


Go Back   World Photography Forum > Photography Equipment > Lenses


Lenses Discussion of Lenses

Reply
 
Thread Tools
  #1  
Old 25-02-11, 12:16
Gidders's Avatar
Gidders Gidders is offline  
Super Moderator
 
Join Date: Dec 2005
Location: West Midlands
Posts: 2,794
Default Canon 70-200 f2.8 IS Mk 1

I've bought one of these off ebay which arrived this morning.

The lens is is great condition but..

when I part press the shutter release there is a click which sounds link a servo as the IS motors activate (followed by a faint hum or whirr as the motors do their stuff)

I have a 24-105 IS and 70-300 IS (non L ) and while I get the motor hum, I don't notice this click.

Is this normal for the 70-200?
__________________
Clive
http://www.alteredimages.uk.com
Reply With Quote
  #2  
Old 25-02-11, 18:21
john crossley john crossley is offline
Senior Member
 
Join Date: Dec 2005
Location: Yorkshire
Posts: 237
Default

Mine makes a clicking noise when the IS is activated. I bought mine new about 4 years ago. Whether it is supposed to or not, I don't know.

There again I think all of my IS lenses click when IS is activated.
Reply With Quote
  #3  
Old 25-02-11, 18:31
john crossley john crossley is offline
Senior Member
 
Join Date: Dec 2005
Location: Yorkshire
Posts: 237
Default

Yeah, I've just checked and they all click when IS is activated.
Reply With Quote
  #4  
Old 25-02-11, 18:49
postcardcv's Avatar
postcardcv postcardcv is online now
Super Moderator
 
Join Date: Dec 2005
Location: Norfolk
Age: 43
Posts: 1,793
Default

just stuck mine to my ear and it does seem to click before humming... no idea why but I guess it is just the way it is with that lens. I'm sure you'll love the lens, I got one last year (changed up from the non-IS f4 version) and have been so impressed with it. Definitely one of my most used lenses.
Reply With Quote
  #5  
Old 25-02-11, 18:58
Gidders's Avatar
Gidders Gidders is offline  
Super Moderator
 
Join Date: Dec 2005
Location: West Midlands
Posts: 2,794
Default

Thanks for the reassurance guys ... now how soon does it start getting light in the morning
__________________
Clive
http://www.alteredimages.uk.com
Reply With Quote
  #6  
Old 22-07-14, 11:32
fotonunta fotonunta is offline  
Guest
 
Join Date: Jul 2014
Location: Brasov
Posts: 7
Default

You should send it to Canon service! That hum can be a mallfunction of IS motor! Be very carefull!
Reply With Quote
  #7  
Old 25-07-14, 16:18
Ade G's Avatar
Ade G Ade G is offline  
Senior Member
 
Join Date: Mar 2014
Location: West Cumbria
Posts: 1,045
Default

Very early, I was out trying to get the milky way the other night, it was still light at nearly 11pm and reckon it is still starting to get light around 4 -4.30am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 21:04.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.