WPF - World Photography Forum
Home Gallery Register FAQ Calendar Search Today's Posts Mark Forums Read

Welcome to World Photography Forum!
Welcome!

Thank you for finding your way to World Photography Forum, a dedicated community for photographers and enthusiasts. There's a variety of forums, a wonderful gallery, and what's more, we are absolutely FREE. You are very welcome to join, take part in the discussion, and post your pictures!

Click here to go to the forums home page and find out more.
Click here to join.


Go Back   World Photography Forum > General Photography > The Photography Forum


The Photography Forum General Photography Related Discussion.

Reply
 
Thread Tools
  #1  
Old 02-04-12, 09:43
LovesRaptors LovesRaptors is offline  
Member
 
Join Date: Apr 2012
Location: South Lanarkshire Scotland
Posts: 15
Default Error 99 Canon EOS 1000d Fault

Could anyone help to remedy this problem, all terminals have been cleaned on Camera and Lens's battery changed and various SD Cards changed, however camera LCD screen still showing error 99 and can not be used, could any member who has had similar problems help me rectify this fault.

Thank you in advance John. (LovesRaptors)
Reply With Quote
  #2  
Old 02-04-12, 09:52
postcardcv's Avatar
postcardcv postcardcv is offline
Super Moderator
 
Join Date: Dec 2005
Location: Norfolk
Age: 39
Posts: 1,525
Default

unfortunately the error 99 code is a very general one so doesn't tell you anything really. If cleaning contacts hasn't solved it then i suspect a trip to a repair centre might be needed.
Reply With Quote
  #3  
Old 02-04-12, 15:25
LovesRaptors LovesRaptors is offline  
Member
 
Join Date: Apr 2012
Location: South Lanarkshire Scotland
Posts: 15
Default

Quote:
Originally Posted by postcardcv View Post
unfortunately the error 99 code is a very general one so doesn't tell you anything really. If cleaning contacts hasn't solved it then i suspect a trip to a repair centre might be needed.
Thank you for the quick reply, we think a trip to the repair centre as you say will be needed,

John.
Reply With Quote
  #4  
Old 03-07-12, 15:58
riddell riddell is offline  
Member
 
Join Date: Nov 2009
Location: Berkhamsted
Posts: 9
Default

Error 99 is often lens contacts, and if you've cleaned them, its possible that there is a fault with one or the other (though as another poster said error 99 is very generic)

But have you tried another lens? It may be that its the lens at fault, not the body

Paul.
www.photographybyriddell.co.uk
Reply With Quote
  #5  
Old 04-07-12, 18:18
surfg1mp's Avatar
surfg1mp surfg1mp is offline  
Senior Member
 
Join Date: Jan 2010
Location: Abingdon, Oxford, UK
Age: 42
Posts: 1,782
Default

Are you using an older lens with an aperture ring? If so, make sure this ring is locked to say f22 or it will give you an error.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 18:52.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.